VTE-0.76.3

Introduction to VTE

The VTE package contains a virtual terminal widget for GTK applications.

[Note]

Note

Development versions of BLFS may not build or run some packages properly if LFS or dependencies have been updated since the most recent stable versions of the books.

Package Information

VTE Dependencies

Required

GTK+-3.24.43, libxml2-2.13.2, and pcre2-10.44

Recommended

Optional

Gi-DocGen-2024.1

Installation of VTE

Install VTE by running the following commands:

mkdir build &&
cd    build &&

meson setup --prefix=/usr --buildtype=release .. &&
ninja

If you have Gi-DocGen-2024.1 installed and wish to build the API documentation for this package, issue:

sed -e "/docdir =/s@\$@/ 'vte-0.76.3'@" \
    -i ../doc/reference/meson.build     &&
meson configure -Ddocs=true             &&
ninja

To test the results, issue ninja test.

Now, as the root user:

ninja install &&
rm -v /etc/profile.d/vte.*

Command Explanations

--buildtype=release: Specify a buildtype suitable for stable releases of the package, as the default may produce unoptimized binaries.

rm -v /etc/profile.d/vte.*: This command removes two files installed in /etc/profile.d that have no use on a LFS system.

-Dgnutls=false: Add this switch if you do not want to enable GnuTLS support.

-Dvapi=false: Add this switch if you do not want to enable vala bindings.

-Dgtk4=false: Add this switch if you do not want to build the GTK-4 version of VTE.

Contents

Installed Program: vte-2.91 and vte-2.91-gtk4
Installed Library: libvte-2.91.so and libvte-2.91-gtk4.so
Installed Directories: /usr/include/vte-2.91, /usr/include/vte-2.91-gtk4, and (optional) /usr/share/doc/vte-0.76.3

Short Descriptions

vte-2.91

is a test application for the VTE libraries

vte-2.91-gtk4

is a test application for the GTK-4 version of the VTE libraries

libvte-2.91.so

is a library which implements a terminal emulator widget for GTK+ 3

libvte-2.91-gtk4.so

is a library which implements a terminal emulator widget for GTK-4