evolution-data-server-3.24.3

Introduction to Evolution Data Server

Evolution Data Server package provides a unified backend for programs that work with contacts, tasks, and calendar information. It was originally developed for Evolution (hence the name), but is now used by other packages as well.

This package is known to build and work properly using an LFS-8.0 platform.

This package is known to build and work properly when built with gcc-7.1.

Package Information

Evolution Data Server Dependencies

Required

Berkeley DB-6.2.32, Gcr-3.20.0, libical-2.0.0, libsecret-0.18.5, libsoup-2.58.1, NSS-3.31, Python-2.7.13, and SQLite-3.19.3.

Recommended

Optional

GTK-Doc-1.25, MIT Kerberos V5-1.15.1, a MTA (that provides a sendmail command), OpenLDAP-2.4.45, Accounts-SSO, Google Authenticator, and libphonenumber

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/evolution-data-server

Installation of Evolution Data Server

Install Evolution Data Server by running the following commands:

mkdir build &&
cd build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr   \
      -DENABLE_UOA=OFF              \
      -DENABLE_VALA_BINDINGS=ON     \
      -DENABLE_INSTALLED_TESTS=ON   \
      -DENABLE_GOOGLE=ON            \
      -DENABLE_GOOGLE_AUTH=OFF      \
      -DWITH_OPENLDAP=OFF           \
      -DWITH_KRB5=OFF               \
      -DENABLE_INTROSPECTION=ON     \
      .. &&
make

To test the results, run make check,

Now, as the root user:

make install

Command Explanations

-DENABLE_GOOGLE_AUTH=OFF: This flag is used to disable the Google Authentication functionality within Evolution Data Server. Omit if you have installed Google Authenticator.

-DENABLE_UOA=OFF: This flag is used to disable Ubuntu Online Accounts support in Evolution Data Server. Remove it if you have installed Accounts-SSO.

-DENABLE_VALA_BINDINGS=ON: This switch enables building the Vala bindings. Remove if you don't have Vala-0.36.3 installed.

[Note]

Note

To enable many of the optional dependencies, review the information from cmake -L CMakeLists.txt for the necessary parameters you must pass to the cmake command.

Contents

Installed Programs: None
Installed Libraries: libcamel-1.2.so, libebackend-1.2.so, libebook-1.2.so, libebook-contacts-1.2.so, libecal-1.2.so, libedata-book-1.2.so, libedata-cal-1.2.so, libedataserver-1.2.so, libedataserverui-1.2.so, and libetestserverutils.so
Installed Directories: /usr/include/evolution-data-server, /usr/lib{,exec}/evolution-data-server, /usr/share/{,installed-tests/}evolution-data-server, /usr/share/gtk-doc/html/{camel,libebackend,libebook}, /usr/share/gtk-doc/html/{libecal,libedata-book,libedata-cal}, /usr/share/gtk-doc/html/{libedataserver,libedataserverui} and /usr/share/pixmaps/evolution-data-server

Short Descriptions

libcamel-1.2.so

is the Evolution MIME message handling library.

libebackend-1.2.so

is the utility library for Evolution Data Server Backends.

libebook-1.2.so

is the client library for Evolution address books.

libecal-1.2.so

is the client library for Evolution calendars.

libedata-book-1.2.so

is the backend library for Evolution address books.

libedata-cal-1.2.so

is the backend library for Evolution calendars.

libedataserver-1.2.so

is the utility library for Evolution Data Server.

libedataserverui-3.0.so

is the GUI utility library for Evolution Data Server.

Last updated on 2017-06-23 13:09:34 -0500