libadwaita-1.1.2

Introduction to libadwaita

The libadwaita package provides additional GTK4 UI widgets for use in developing user interfaces. It is used primarily for GNOME applications.

[Note]

Note

Development versions of BLFS may not build or run some packages properly if dependencies have been updated since the most recent stable versions of the book.

Package Information

libadwaita Dependencies

Required

GTK-4.6.5

Recommended

Optional

GTK-Doc-1.33.2

User Notes: https://wiki.linuxfromscratch.org/blfs/wiki/libadwaita

Installation of libadwaita

Install libadwaita by running the following commands:

mkdir build &&
cd    build &&

meson --prefix=/usr --buildtype=release .. &&
ninja

To test the results, issue: ninja test. The tests must be run from a graphical session.

Now, as the root user:

ninja install

Command Explanations

--buildtype=release: Specify a buildtype suitable for stable releases of the package, as the default may produce unoptimized binaries.

-Dgtk_doc=true: Use this option if you have GTK-Doc-1.33.2 installed and wish to install the documentation.

Contents

Installed Programs: adwaita-1-demo
Installed Libraries: libadwaita-1.so
Installed Directories: /usr/include/libadwaita-1

Short Descriptions

adwaita-1-demo

provides an example of how to use the libadwaita library

libadwaita-1.so

provides additional GTK widgets for use in creating user interfaces