volume_key-0.3.12

Introduction to volume_key

The volume_key package provides a library for manipulating storage volume encryption keys and storing them separately from volumes to handle forgotten passphrases.

This package is known to build and work properly using an LFS-11.0 platform.

Package Information

volume_key Dependencies

Required

cryptsetup-2.3.6, GLib-2.70.0, GPGME-1.16.0, and NSS-3.69.1

Recommended

User Notes: https://wiki.linuxfromscratch.org/blfs/wiki/volume_key

Installation of volume_key

Install volume_key by running the following commands:

[Note]

Note

This package expands to the directory volume_key-volume_key-0.3.12.

autoreconf -fiv              &&
./configure --prefix=/usr    \
            --without-python &&
make

This package does not come with a functioning test suite.

Now, as the root user:

make install

Command Explanations

--without-python: This parameter prevents building the Python 2 bindings, if Python-2.7.18 is installed.

--without-python3: Use this option if you do not want to build the Python 3 bindings. In this case, SWIG-4.0.2 is not needed.

Contents

Installed Program: volume_key
Installed Library: libvolume_key.so
Installed Directory: /usr/include/volume_key

Short Descriptions

volume_key

manages encrypted volume keys and passphrases

volume_key.so

contains API functions for managing encrypted volume keys

Last updated on Mon Sep 6 19:42:49 2021 +