Vte-0.28.2

Introduction to Vte

Vte is a library (libvte) implementing a terminal emulator widget for GTK+ 2, and a minimal demonstration application (vte) that uses libvte.

[Note]

Note

Development versions of BLFS may not build or run some packages properly if dependencies have been updated since the most recent stable versions of the book.

Package Information

Vte Dependencies

Required

GTK+-2.24.33

Optional

gobject-introspection-1.72.0, GTK-Doc-1.33.2 and PyGTK-2.24.0

User Notes: https://wiki.linuxfromscratch.org/blfs/wiki/vte2

Installation of Vte

Install Vte by running the following commands:

./configure --prefix=/usr \
            --libexecdir=/usr/lib/vte \
            --disable-static  &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--libexecdir=/usr/lib/vte : both this package and VTE-0.68.0 install files of the same name. This switch ensures that they do not overwrite each other if both are installed.

--disable-static: This switch prevents installation of static versions of the libraries.

Contents

Installed Program: vte
Installed Library: libvte.so
Installed Directories: /usr/include/vte-0.0, /usr/lib/vte, /usr/share/gtk-doc/html/vte-0.0 and /usr/share/vte

Short Descriptions

vte

is a simple terminal emulator

libvte.so

contains the Vte API functions