Gcr-4.3.0

Introduction to Gcr

The Gcr package contains libraries used for displaying certificates and accessing key stores. It also provides the viewer for crypto files on the GNOME Desktop.

[Note]

Note

Development versions of BLFS may not build or run some packages properly if LFS or dependencies have been updated since the most recent stable versions of the books.

Package Information

Gcr Dependencies

Required

GLib-2.80.4 (GObject Introspection recommended), libgcrypt-1.11.0, and p11-kit-0.25.5

Recommended

Optional

Gi-DocGen-2024.1, GnuTLS-3.8.6, and Valgrind-3.23.0

Installation of Gcr

[Note]

Note

Both gcr-3 and gcr-4 are coinstallable. This version of the package is used to support GTK-4 applications, such as gnome-shell-46.3.1 and Epiphany-46.2.

Install Gcr by running the following commands:

mkdir build &&
cd    build &&

meson setup --prefix=/usr       \
            --buildtype=release \
            -Dgtk_doc=false     \
            ..                  &&
ninja

If you have Gi-DocGen-2024.1 installed and wish to build the API documentation for this package, issue:

sed -e "/install_dir/s@,\$@ / 'gcr-4.3.0'&@" \
    -i ../docs/*/meson.build                 &&
meson configure -Dgtk_doc=true               &&
ninja

To test the results, issue: ninja test. The tests must be run from an X Terminal or similar.

Now, as the root user:

ninja install

Command Explanations

--buildtype=release: Specify a buildtype suitable for stable releases of the package, as the default may produce unoptimized binaries.

-Dgtk4=false: Use this switch if you haven't installed GTK-4.14.4. Note that gcr-viewer will not be installed if this is passed to meson.

-Dssh_agent=false: Use this switch if you haven't installed OpenSSH-9.8p1, and wish to disable ssh compatibility.

-Dgtk_doc=true: Allow building this package without Gi-DocGen-2024.1 installed. If you have Gi-DocGen-2024.1 installed and you wish to rebuild and install the API documentation, a meson configure command will reset this option.

-Dcrypto=gnutls: Use this switch if you have GnuTLS-3.8.6 installed and wish to use it instead of libgcrypt-1.11.0.

Contents

Installed Program: gcr-viewer-gtk4
Installed Libraries: libgck-2.so, libgcr-4.so
Installed Directories: /usr/include/gck-2, /usr/include/gcr-4, and /usr/share/gtk-doc/html/{gcr,gck}

Short Descriptions

gcr-viewer-gtk4

is used to view certificates and key files

libgck-2.so

contains GObject bindings for PKCS#11

libgcr-4.so

contains functions for accessing key stores and displaying certificates