libqalculate-4.2.0

Introduction to libqalculate

The libqalculate package contains a library that provides functions for a multi-purpose calculator.

[Note]

Note

Development versions of BLFS may not build or run some packages properly if dependencies have been updated since the most recent stable versions of the book.

Package Information

libqalculate Dependencies

Required

cURL-7.84.0 and libxml2-2.9.14

Optional

Doxygen-1.9.4

User Notes: https://wiki.linuxfromscratch.org/blfs/wiki/libqalculate

Installation of libqalculate

Install libqalculate by running the following commands:

./configure --prefix=/usr \
        --disable-static          \
        --docdir=/usr/share/doc/libqalculate-4.2.0 &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--disable-static: This switch prevents installation of static versions of the libraries.

Contents

Installed Programs: qalc
Installed Library: libqalculate.so
Installed Directories: /usr/include/libqalculate, /usr/share/doc/libqalculate-4.2.0, and /usr/share/qalculate

Short Descriptions

qalc

is a powerful and easy to use command line calculator

libqalculate.so

contains the libqalculate API functions