libxfcegui4-4.10.0

Introduction to libxfcegui4

The libxfcegui4 package provides the basic GUI functions used by Xfce.

This package is known to build and work properly using an LFS-7.6 systemd platform.

Package Information

libxfcegui4 Dependencies

Required

libglade-2.6.4 and libxfce4util-4.10.1

Optional

GTK-Doc-1.20

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/libxfcegui4

Installation of libxfcegui4

Install libxfcegui4 by running the following commands:

./configure --prefix=/usr --disable-static &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--disable-static: This switch prevents installation of static versions of the libraries.

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Programs: None
Installed Libraries: libxfcegui4.so and libxfce4.so
Installed Directories: /usr/include/xfce4/libxfcegui4 and /usr/share/gtk-doc/html/libxfcegui4

Short Descriptions

libxfcegui4.so

contains the basic GUI functions used by Xfce.

Last updated on 2014-08-25 18:16:47 +0000