asymptote-2.47

Introduction to asymptote

Asymptote is a powerful descriptive vector graphics language that provides a natural coordinate-based framework for technical drawing. Labels and equations can be typeset with LaTeX.

This package is known to build and work properly using an LFS-8.3 platform.

Package Information

Required

ghostscript-9.25 and texlive-20180414

Recommended

Optional

fftw-3.3.8, Gsl-2.5, and libsigsegv-2.12

Optional (at runtime, to use xasy)

PyQt5 (not tested), which has a build dependency of Qt-5.11.2

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/asymptote

Installation of asymptote

Install asymptote by running the following commands:

export TEXARCH=$(uname -m | sed -e 's/i.86/i386/' -e 's/$/-linux/') &&

./configure --prefix=/opt/texlive/2018                          \
            --bindir=/opt/texlive/2018/bin/$TEXARCH             \
            --datarootdir=/opt/texlive/2018/texmf-dist          \
            --infodir=/opt/texlive/2018/texmf-dist/doc/info     \
            --libdir=/opt/texlive/2018/texmf-dist               \
            --mandir=/opt/texlive/2018/texmf-dist/doc/man       \
            --enable-gc=system                                  \
            --with-latex=/opt/texlive/2018/texmf-dist/tex/latex \
            --with-context=/opt/texlive/2018/texmf-dist/tex/context/third &&

make

To test the results, issue: make check. Note that if PyQt5 has not been installed some UI tests will report that pyuic5 and other commands are not found, followed by ''Error 127 (ignored)'.

Now, as the root user:

make install

Command Explanations

--prefix=, --bindir=, --datarootdir=, --infodir=, --mandir= ... : these switches ensure that the files installed from source will overwrite any corresponding files previously installed by install-tl-unx so that the alternative methods of installing texlive are consistent..

--libdir=/opt/texlive/2018/texmf-dist;: This parameter ensures that the asymptote directory will similarly overwrite any files installed by install-tl-unx.

--enable-gc=system: this ensures that the system version of libgc.so will be used instead of the version shipped with this package.

--with-latex= ... --with-context=: These switches ensure that style files and a tex file will be installed into the texlive directories instead of creating a texmf-local directory for them.

Contents

Installed Programs: asy, xasy
Installed Libraries: None
Installed Directory: /opt/texlive/2018texmf-dist/asymptote, /opt/texlive/2018/doc/asymptote, /opt/texlive/2018/info/asymptote

Short Descriptions

asy

is a vector graphics program.

xasy

is a Python3 script providing a Qt5 GUI for asy.

Last updated on 2018-08-26 21:27:55 -0500