gst-plugins-bad-0.10.23

Introduction to Gstreamer Bad Plug-ins

The GStreamer Bad Plug-ins package contains a set a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use. Also see the gst-plugins-good-0.10.31, gst-plugins-ugly-0.10.19 and gst-ffmpeg-0.10.13 packages.

This package is known to build and work properly using an LFS-7.6 systemd platform.

[Note]

Note

GStreamer 1.0 series is not API or ABI compatible with GStreamer 0.10 series and both can be installed on the same system.

Package Information

GStreamer Bad Plug-ins Dependencies

Required

gst-plugins-base-0.10.36

Recommended

Optional

celt, cURL-7.38.0, Dirac, DirectFB, FAAD2-2.7, Flite, Game Music Emu, GSM, JasPer-1.900.1, LADSPA, libass-0.11.2, libcdaudio, libdc1394, libdca, libiptcdata, libkate, libmimic, libmms, libmodplug, libmpcdec, libmusicbrainz-2.1.5, libofa, librsvg-2.40.5, libsndfile-1.0.25, libvdpau-0.8, MJPEG Tools, neon-0.30.1, OpenAL, ORC, rtmpdump, Schroedinger, SDL-1.2.15, SoundTouch, SpanDSP, VO AACENC, VO AMRWBENC, WildMidi, ZBAR and ZVBI

Optional, for the unit regression tests

Valgrind-3.10.0

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gst-plugins-bad

Installation of GStreamer Bad Plug-ins

Install Gstreamer Bad Plug-ins by running the following commands:

./configure --prefix=/usr      \
            --with-gtk=3.0     \
            --disable-examples \
            --disable-static   \
            --with-package-name="GStreamer Bad Plugins 0.10.23 BLFS" \
            --with-package-origin="http://www.linuxfromscratch.org/blfs/view/systemd/" &&
make

To test the results, issue: make check. Note that tests for some of the items may fail.

Now, as the root user:

make install

Command Explanations

--with-gtk=3.0: Build against GTK+ 3 instead of the default GTK+ 2; recommended for a GNOME Desktop.

--disable-examples: If the dependencies for the camera driver have been satisfied, the associated example code fails to build.

Contents

Installed Programs: None
Installed Libraries: libgstbasecamerabinsrc-0.10.so, libgstbasevideo-0.10.so, libgstcodecparsers-0.10.so, libgstphotography-0.10.so, libgstsignalprocessor-0.10.so and libgstvdp-0.10.so
Installed Directories: /usr/include/gstreamer-0.10/gst/{basecamerabinsrc,codecparsers,interfaces}, /usr/include/gstreamer-0.10/gst/{signalprocessor,vdpau,video} and /usr/share/gtk-doc/gst-plugins-bad-libs-0.10

Last updated on 2014-08-26 02:22:46 +0000