Polkit-Qt-0.112.0

Introduction to Polkit-Qt

Polkit-Qt provides an API to polkit in the Qt environment.

This package is known to build and work properly using an LFS-7.7-systemd platform.

Package Information

Polkit-Qt Dependencies

Required

CMake-3.5.2, Polkit-0.113

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/polkit-qt

Installation of Polkit-Qt

Install Polkit-Qt by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KDE_PREFIX \
      -DCMAKE_BUILD_TYPE=Release       \
      -DCMAKE_INSTALL_LIBDIR=lib       \
      -DUSE_QT4=TRUE                   \
      -Wno-dev .. &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

-DCMAKE_BUILD_TYPE=Release: This switch is used to apply higher level of the compiler optimizations.

-DCMAKE_INSTALL_LIBDIR=lib: This switch is used to get libraries to install to $KDE_PREFIX/lib instead of $KDE_PREFIX/lib64 on a 64 bit system.

Contents

Installed Programs: none
Installed Libraries: libpolkit-qt5-agent-1.so, libpolkit-qt5-core-1.so, and libpolkit-qt5-gui-1.so
Installed Directories: /usr/include/polkit-qt5-1 and /usr/lib/cmake/PolkitQt5-1

Last updated on 2016-06-09 18:28:10 -0500