gnome-bluetooth-3.14.0

Introduction to GNOME Bluetooth

The GNOME Bluetooth package contains tools for managing and manipulating Bluetooth devices using the GNOME Desktop.

This package is known to build and work properly using an LFS-7.6 systemd platform.

Package Information

GNOME Bluetooth Dependencies

Required

GTK+-3.14.6

Recommended

Optional

GTK-Doc-1.21

Required (Runtime)

BlueZ-5.26 and Systemd (for Logind)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gnome-bluetooth

Installation of GNOME Bluetooth

Install GNOME Bluetooth by running the following commands:

./configure --prefix=/usr &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Programs: bluetooth-sendto
Installed Libraries: libgnome-bluetooth.so
Installed Directories: /usr/include/gnome-bluetooth, /usr/share/gnome-bluetooth, /usr/share/gtk-doc/html/gnome-bluetooth and /usr/share/help/*/gnome-bluetooth

Short Descriptions

bluetooth-sendto

is a GTK+ application for transferring files over Bluetooth.

libgnome-bluetooth.so

contains the GNOME Bluetooth API functions.

Last updated on 2014-09-30 12:02:16 +0000