Rep-gtk-0.90.8.3

Introduction to Rep-gtk

The rep-gtk package contains a Lisp and GTK binding. This is useful for extending GTK-2 and GDK libraries with Lisp. Starting at rep-gtk-0.15, the package contains the bindings to GTK and uses the same instructions. Both can be installed, if needed.

This package is known to build and work properly using an LFS 7.8-systemd platform.

Package Information

Rep-gtk Dependencies

Required

GTK+-2.24.30 and librep-0.92.6

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/rep-gtk

Installation of Rep-gtk

Install rep-gtk by running the following commands:

./autogen.sh --prefix=/usr &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Contents

Installed Programs: None
Installed Libraries: Lisp bindings
Installed Directory: /usr/include/rep-gtk and /usr/lib/rep/gui

Short Descriptions

Lisp bindings

are libraries stored in /usr/lib/rep/gui/ that assist communication between Lisp and the GTK libraries.

Last updated on 2016-06-09 18:28:10 -0500