Harfbuzz-0.9.35

Introduction to Harfbuzz

The Harfbuzz package contains an OpenType text shaping engine.

This package is known to build and work properly using an LFS-7.5 platform.

Package Information

Harfbuzz Dependencies

Recommended

Optional

Cairo-1.12.16, gobject-introspection-1.40.0, GTK-Doc-1.20, and Graphite2-1.2.4

[Warning]

Warning

Recommended dependencies are not strictly required to build the package. However, you might not get expected results at runtime if you don't install them. Please do not report bugs with this package if you have not installed the recommended dependencies.

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/harfbuzz

Installation of Harfbuzz

If you wish to run the test suite, run the following commands, to disable a test that fails:

sed -i '/arabic-fallback-shaping.tests/d' test/shaping/Makefile.am &&
autoreconf -f -i

Install Harfbuzz by running the following commands:

./configure --prefix=/usr --with-gobject &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--with-gobject: This switch enables building of the Harfbuzz GObject wrapper. Remove it if you did not install GLib.

--with-graphite2: This switch enables Graphite2 support.

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Programs: hb-ot-shape-closure, hb-shape, and hb-view
Installed Libraries: libharfbuzz.so, libharfbuzz-gobject.so and libharfbuzz-icu.so
Installed Directories: /usr/include/harfbuzz and /usr/share/gtk-doc/html/harfbuzz

Short Descriptions

libharfbuzz.so

contains functions for complex text shaping.

Last updated on 2014-08-15 10:18:18 +0000