ModemManager-1.4.0

Introduction to ModemManager

ModemManager provides a unified high level API for communicating with mobile broadband modems, regardless of the protocol used to communicate with the actual device.

This package is known to build and work properly using an LFS-7.6 systemd platform.

Package Information

ModemManager Dependencies

Required

Systemd (for GUdev)

Recommended

Optional

GTK-Doc-1.20

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/ModemManager

Installation of ModemManager

Install ModemManager by running the following commands:

./configure --prefix=/usr        \
            --sysconfdir=/etc    \
            --localstatedir=/var \
            --disable-static     &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--disable-static: This switch prevents installation of static versions of the libraries.

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Configuring ModemManager

Systemd Units

To start the ModemManager daemon at boot, enable the previously installed systemd unit by running the following command as the root user:

systemctl enable ModemManager

Contents

Installed Programs: mmcli and ModemManager
Installed Libraries: libmm-glib.so
Installed Directories: /usr/include/libmm-glib, /usr/include/ModemManager, /usr/lib/ModemManager, /usr/share/gtk-doc/html/libmm-glib, and /usr/share/gtk-doc/html/ModemManager

Short Descriptions

mmcli

is an utility used to control and monitor the ModemManager.

ModemManager

is a D-Bus service used to communicate with modems.

libmm-glib.so

contains API functions for communicating with mobile broadband modems, regardless of the protocol used to communicate with the actual device.

Last updated on 2014-08-30 10:26:57 +0000