libglade-2.6.4

Introduction to libglade

The libglade package contains libglade libraries. These are useful for loading Glade interface files in a program at runtime.

This package is known to build and work properly using an LFS-7.6 platform.

Package Information

libglade Dependencies

Required

libxml2-2.9.2 and GTK+-2.24.25

Optional

Python-2.7.9 and GTK-Doc-1.21

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/libglade

Installation of libglade

Install libglade by running the following commands:

sed -i '/DG_DISABLE_DEPRECATED/d' glade/Makefile.in &&
./configure --prefix=/usr --disable-static &&
make

To test the results, issue: make check. One of the tests, test-convert, is known to fail.

Now, as the root user:

make install

Command Explanations

sed -i '/DG_DISABLE_DEPRECATED/d': Some of the glib functions that libglade uses were declared deprecated in glib-2.30. This sed removes the G_DISABLE_DEPRECATED CFLAG.

--disable-static: This switch prevents installation of static versions of the libraries.

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Program: libglade-convert (requires python)
Installed Library: libglade-2.0.so
Installed Directories: /usr/{include/libglade-2.0/glade,share/{gtk-doc/html/libglade, xml/libglade}}

Short Descriptions

libglade-convert

is used to convert old Glade interface files to Glade-2.0 standards.

libglade-2.0.so

contain the functions necessary to load Glade interface files.

Last updated on 2014-09-10 16:45:01 +0000