keybinder2-0.3.0

Introduction to keybinder2

The keybinder2 package contains a utility library registering global X keyboard shortcuts.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

keybinder2 Dependencies

Required

GTK+-2.24.31

Recommended

Optional

GTK-Doc-1.27 and Lua-5.3.4 (currently broken, because older lua version is required)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/keybinder2

Installation of keybinder2

Install keybinder2 by running the following commands:

./configure --prefix=/usr --disable-lua &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--disable-lua: Use this switch to disable Lua-5.3.4 bindings (currently broken, because older lua version is required).

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Programs: None
Installed Library: libkeybinder.so and /usr/lib/python2.7/site-packages/keybinder/_keybinder.so
Installed Directories: /usr/lib/python2.7/site-packages/keybinder and /usr/share/gtk-doc/html/keybinder

Short Descriptions

libkeybinder.so

is the library that registers global X keyboard shortcuts.

Last updated on 2017-08-28 17:14:37 -0500