Introduction to Gtkmm

The Gtkmm package provides a C++ interface to GTK+ 2. It can be installed alongside Gtkmm-3.18.0 (the GTK+ 3 version) with no namespace conflicts.

This package is known to build and work properly using an LFS-7.8 platform.

Package Information

Gtkmm Dependencies


Atkmm-2.24.2, GTK+-2.24.28 and Pangomm-2.38.1

User Notes:

Installation of Gtkmm

First, fix the documents directory name:

sed -e '/^libdocdir =/ s/$(book_name)/gtkmm-2.24.4/' \
    -i docs/

Install Gtkmm by running the following commands:

CXXFLAGS="-g -O2 -std=c++11" ./configure --prefix=/usr &&

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

CXXFLAGS="-g -O2 -std=c++11" ./configure...: while Gtkmm-2.24.4 has not yet been ported to the 2011 ISO C++ standard, all its dependencies have. -std=c++11 has to be used as an option to g++. We pass it into CXXFLAGS together with the default options.


Installed Programs: None
Installed Libraries: and
Installed Directories: /usr/include/gdkmm-2.4, /usr/include/gtkmm-2.4, /usr/lib/gdkmm-2.4, /usr/lib/gtkmm-2.4, and /usr/share/{devhelp/books/gtkmm-2.4,doc/gtkmm-2.24.4}

Short Descriptions

contains the GDK API classes.

contains the GTK+ API classes.

Last updated on 2015-11-30 17:32:50 -0600