juffed-0.10.r71.gc3c1a3f

Introduction to JuffEd

The JuffEd package is a Qt based editor with support for multiple tabs. It is simple and clear, but very powerful. It supports language syntax highlighting, auto-indents in accordance with file type, code blocks folding, matching braces highlighting with instant jumps between them, powerful search and replacing text using regular expressions (including multiline ones) with the opportunity to use matches \1, \2, … in substitutions, a terminal emulator, saving named sessions and many other features.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

The source tarball shown above was created by the BLFS team by cloning the source code repository, finding the correct version to rename accordingly the source code directory, removing .git directory and .gitignore file, and finally making the compressed tarball. No other modification has been made.

JuffEd Dependencies

Required

qscintilla-2.10.1

Recommended

Optional

desktop-file-utils-0.23 and Enca

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/juffed

Installation of JuffEd

For compilation with Qt4, see “Command Explanations” below. Install JuffEd by running the following commands:

sed -i 's/"64"/""/' cmake/LibSuffix.cmake &&

mkdir -v build &&
cd       build &&

cmake -DCMAKE_INSTALL_PREFIX=$LXQT_PREFIX \
      -DCMAKE_BUILD_TYPE=Release          \
      -DBUILD_TERMINAL=ON                 \
      -DUSE_QT5=true                      \
      ..       &&

LIBRARY_PATH=$LXQT_PREFIX/lib make

The choice of /usr prefix is due to the general characteristics of this program, which can be used without LXQt.

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

sed ... LibSuffix.cmake: Removes the 64 from /lib64.

LIBRARY_PATH=$LXQT_PREFIX/lib: This environment variable is needed for the linker to find a required library.

-DBUILD_TERMINAL=ON: This switch is used in order to enable building the terminal. Toggle to “OFF” or remove the switch, if you do not wish it.

-DUSE_QT5=true: This switch is used in order to build this application linked to Qt5. Toggle to “false”, if you prefer to use Qt4.

Contents

Installed Program: juffed
Installed Libraries: libjuff.so, libjuffed-engine-qsci.so and plugins under /usr/lib/juffed/plugins
Installed Directory: /usr/{include,lib,share}/juffed

Short Descriptions

juffed

is a Qt based text editor.

libjuff.so

contains the JuffEd API functions.

libjuffed-engine-qsci.so

contains the QScintilla bindings.

Last updated on 2017-08-28 17:14:37 -0500