gstreamer-vaapi-1.12.4

Introduction to gstreamer-vaapi

The gstreamer-vaapi package contains a gstreamer plugin for hardware accelerated video decode/encode for the prevailing coding standards today (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

gstreamer-vaapi Dependencies

Required

gstreamer-1.12.4, gst-plugins-base-1.12.4, gst-plugins-bad-1.12.4, and libva-2.0.0

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gstreamer10-vaapi

Installation of gstreamer-vaapi

Install gstreamer-vaapi by running the following commands:

./configure --prefix=/usr &&
make

Tests can be run manually in the tests directory. They need a running X Window display.

Now, as the root user:

make install

Contents

Installed Programs: None
Installed Library: /usr/lib/gstreamer-1.0/libgstvaapi.so
Installed Directory: /usr/share/gtk-doc/html/gstreamer-vaapi-plugins-1.0

Last updated on 2017-12-08 17:47:19 -0600