lxqt-policykit-0.12.0

Introduction to lxqt-policykit

The lxqt-policykit package is the LXQt PolicyKit agent.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

lxqt-policykit Dependencies

Required

liblxqt-0.12.0, polkit-qt-0.112.0

Optional

git-2.15.1 (to download translation files) or lxqt-l10n-0.12.0 (to add localization files)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/lxqt-policykit

Installation of lxqt-policykit

Install lxqt-policykit by running the following commands:

mkdir -v build &&
cd       build &&

cmake -DCMAKE_INSTALL_PREFIX=$LXQT_PREFIX \
      -DCMAKE_BUILD_TYPE=Release          \
      -DPULL_TRANSLATIONS=no              \
      ..                                  &&

make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

-DPULL_TRANSLATIONS=no: Removes the need for git-2.15.1, which would otherwise be requested to download the translation files.

Contents

Installed Program: lxqt-policykit-agent
Installed Libraries: None
Installed Directory: None

Short Descriptions

lxqt-policykit-agent

is the LXQt PolicyKit agent.

Last updated on 2017-10-27 11:21:45 -0500