lxqt-panel-0.11.1

Introduction to lxqt-panel

The lxqt-panel package contains a lightweight X11 desktop panel.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

lxqt-panel Dependencies

Required

KDE Frameworks-5.37.0 or (kguiaddons-5.37.0 for lxqt and solid-5.37.0 for lxqt) (keyboard indicator plugin), lxqt-globalkeys-0.11.1, libdbusmenu-qt-0.9.3+16.04.20160218, liblxqt-0.11.1, lxmenu-data-0.1.5, and menu-cache-1.0.2

Recommended

Optional

git-2.14.2 (to download translation files) or lxqt-l10n-0.11.2 (to add localization files)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/lxqt-panel

Installation of lxqt-panel

Install lxqt-panel by running the following commands:

sed -e 's:<KF5/KWindowSystem/:<:'               \
    -i plugin-taskbar/lxqttaskgroup.{h,cpp}     &&

sed -e '/kbdinfo.h/i #undef explicit'           \
    -i plugin-kbindicator/src/x11/kbdlayout.cpp &&

mkdir -v build &&
cd       build &&

cmake -DCMAKE_INSTALL_PREFIX=$LXQT_PREFIX \
      -DCMAKE_BUILD_TYPE=Release          \
      -DPULL_TRANSLATIONS=no              \
      -DCMAKE_INSTALL_LIBDIR=lib          \
      ..                                  &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

sed ... plugin-taskbar/lxqttaskgroup.{h,cpp}: Removes a hard coded directory from an include file and allows the system to find it.

sed ... kbdlayout.cpp: Fixes an upstream workaround for a namespace conflict. See this archlinux patch.

-DPULL_TRANSLATIONS=no: Removes the need for git-2.14.2, which would otherwise be requested to download the translation files.

-D<plugin>_PLUGIN=no: Disable <plugin>, where <plugin> may be CLOCK, COLORPICKER, CPULOAD, DIRECTORYMENU, DESKTOPSWITCH, KBINDICATOR, MAINMENU, MOUNT, QUICKLAUNCH, SENSORS, SHOWDESKTOP, NETWORKMONITOR, SYSSTAT, TASKBAR, STATUSNOTIFIER, TRAY, VOLUME, WORLDCLOCK, or SPACER,

-DVOLUME_USE_<backend>=no: Disable support for <backend> in volume plugin, where backend is ALSA or PULSEAUDIO.

Contents

Installed Program: lxqt-panel
Installed Libraries: several plugins under $LXQT_PREFIX/lib/lxqt-panel
Installed Directories: /etc/xdg/lxqt, $LXQT_PREFIX/share/lxqt/lxqt-panel and $LXQT_PREFIX/lib/lxqt-panel

Short Descriptions

lxqt-panel

is a lightweight Qt5 based panel for the LXQt Desktop.

Last updated on 2017-08-31 03:16:09 -0500