lximage-qt-0.5.1

Introduction to lximage-qt

The lximage-qt package contains a lightweight image viewer and screenshot program.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

lximage-qt Dependencies

Required

libexif-0.6.21 and libfm-qt-0.11.2

Optional

git-2.14.2 (to download translation files) or lxqt-l10n-0.11.2 (to add localization files)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/lximage-qt

Installation of lximage-qt

Install lximage-qt by running the following commands:

mkdir -v build &&
cd       build &&

cmake -DCMAKE_BUILD_TYPE=Release          \
      -DCMAKE_INSTALL_PREFIX=$LXQT_PREFIX \
      -DPULL_TRANSLATIONS=no              \
      ..       &&

make

This package does not come with a test suite.

Now, as the root user:

make install

If you installed in /opt, again as the root user:

ln -svf $LXQT_PREFIX/share/applications/lximage-qt.desktop \
        /usr/share/applications &&

ln -svf $LXQT_PREFIX/share/applications/lximage-qt-screenshot.desktop \
        /usr/share/applications

If you have xdg-utils-1.1.2 installed, as the root user, run xdg-icon-resource forceupdate --theme hicolor.

Command Explanations

-DPULL_TRANSLATIONS=no: Removes the need for git-2.14.2, which would otherwise be requested to download the translation files.

Contents

Installed Program: lximage-qt
Installed Libraries: None
Installed Directory: None

Short Descriptions

lximage-qt

is a lightweight image viewer and screenshot program. There is a menu entry at Utilities for the screenshot program. From command line, obtain a full screen or window shot by running lximage-qt --screenshot.

Last updated on 2017-08-31 10:29:49 -0500