Gwenview-18.12.2

Introduction to Gwenview

Gwenview is a fast and easy-to-use image viewer for KDE.

This package is known to build and work properly using an LFS-8.4 platform.

Package Information

Additional Downloads

Gwenview Dependencies

Required

Exiv2-0.27.0, KDE Frameworks-5.55.0, and Little CMS-2.9

Recommended

Optional

KF5Kipi

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gwenview

Installation of Gwenview

First, fix several files so that Exiv2-0.27.0 is properly found and used:

patch -Np1 -i ../gwenview-18.12.2-exiv2_0.27-1.patch

Install Gwenview by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KF5_PREFIX \
      -DCMAKE_BUILD_TYPE=Release         \
      -DBUILD_TESTING=OFF                \
      -Wno-dev .. &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Contents

Installed Program: gwenview
Installed Libraries: libgwenviewlib.so and gvpart.so
Installed Directories: $KF5_PREFIX/share/{kxmlgui5/gvpart,kxmlgui5/org.kde.gwenview,gwenview,/doc/HTML/en/gwenview}

Short Descriptions

gwenview

is the KDE image viewer.

Last updated on 2019-02-18 15:50:23 -0600