Attica-0.4.2

Introduction to Attica

Attica is a library to access "Open Collaboration Service" providers.

This package is known to build and work properly using an LFS-7.7 platform.

This package is known to build and work properly using the gcc-5 compiler.

Package Information

Attica Dependencies

Required

CMake-3.3.0 and Qt-4.8.7

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/attica

Installation of Attica

Install Attica by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KDE_PREFIX \
      -DCMAKE_BUILD_TYPE=Release         \
      -DQT4_BUILD=ON                     \
      -Wno-dev .. &&
make

To test the results, issue make test.

Now, as the root user:

make install

Command Explanations

-DCMAKE_BUILD_TYPE=Release: This switch is used to apply a higher level of compiler the optimizations.

-DQT4_BUILD=ON: This switch forces the package to build against Qt4 even if Qt5 is present on the system.

Contents

Installed Programs: none
Installed Libraries: libattica.so
Installed Directories: $KDE_PREFIX/include/attica

Last updated on 2015-06-24 23:03:07 +0000