Tracker-miners-2.3.1

Introduction to Tracker-miners

The Tracker-miners package contains a set of data extractors for Tracker.

This package is known to build and work properly using an LFS-9.0 platform.

Package Information

Tracker-miners Dependencies

Required

gst-plugins-base-1.16.1, Tracker-2.3.1, Exempi-2.5.1, and gexiv2-0.12.0

Recommended

Optional

CMake-3.15.5, DConf-0.34.0, libgsf-1.14.46, libseccomp-2.4.2, taglib-1.11.1, totem-pl-parser-3.26.3, UPower-0.99.11, libcue, libosinfo, and gupnp

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/tracker-miners

Installation of Tracker-miners

Install Tracker-miners by running the following commands:

mkdir build &&
cd    build &&

meson --prefix=/usr .. &&
ninja

To test the results, issue: ninja test. Three tests, test-image-1, xmp-loaded-1, and test_external_cue_sheet, are known to fail.

Now, as the root user:

ninja install

Command Explanations

-Dminer_rss=false: Use this option if you have not installed the recommended dependency libgrss.

Contents

Installed Programs: None
Installed Libraries: libtracker-extract.so, and several modules under /usr/lib/tracker-miners-2.0.
Installed Directories: /usr/lib/tracker-miners-2.0 and /usr/share/tracker-miners

Last updated on 2019-10-15 12:32:59 -0500