ImageMagick-6.9.9-23

Introduction to ImageMagick-6 libraries

ImageMagick underwent many changes in its libraries between versions 6 and 7. Most packages in BLFS which use ImageMagick can use version 7, but for the others this page will install only the libraries, headers and general documentation (not programs, manpages, perl modules), and it will rename the unversioned pkgconfig files so that they do not overwrite the same-named files from version 7.

This package is known to build and work properly using an LFS-8.1 platform.

Package Information

Additional Downloads

[Note]

Note

The ImageMagick source releases are updated frequently and the version shown above may no longer be available from the download locations. You can download a more recent version and use the existing BLFS instructions to install it. Chances are that it will work just fine, but this has not been tested by the BLFS team. If the package version shown above is not available from the locations shown above, or from the legacy/ directory at ftp.ImageMagick.org/pub/ImageMagick you can download it from the BLFS package server at Oregon State University: ftp://ftp.osuosl.org/pub/blfs/conglomeration/ImageMagick/.

ImageMagick-6 Dependencies

Recommended

The optional dependencies listed below should be installed if you need support for the specific format or the conversion tool the dependency provides. Many of the dependencies' capabilities and uses are described in the “MAGICK DELEGATES” section of the README.txt file located in the source tree. Additional information about the dependencies can be found in the Install-unix.txt file located in the source tree as well as issuing the ./configure --help command. A summary of this information, as well as some additional notes can be viewed on-line at http://www.imagemagick.org/script/advanced-unix-installation.php.

Optional System Utilities

Cups-2.2.6, cURL-7.57.0, FFmpeg-3.4, fftw-3.3.7, p7zip-16.02 (LZMA), SANE-1.0.27, Wget-1.19.2, xdg-utils-1.1.2, xterm-330, Dmalloc, Electric Fence, PGP or GnuPG-2.2.3 (you'll have to do some hacking to use GnuPG), Profiles, and ufraw (for raw formats listed in http://www.imagemagick.org/www/formats.html)

Optional Graphics Libraries

JasPer-2.0.14, Little CMS-1.19 or Little CMS-2.9, libexif-0.6.21, libjpeg-turbo-1.5.2, libpng-1.6.32, libraw-0.18.6 (RAW_R), librsvg-2.40.19, LibTIFF-4.0.9, libwebp-0.6.1, OpenJPEG-2.3.0, Pango-1.40.14, DjVuLibre, FlashPIX (libfpx), FLIF, JBIG-KIT, libgxps, libraqm, Liquid Rescale, OpenEXR, and RALCGM (or ralcgm)

Optional Graphics Utilities

Dejavu fonts, ghostscript-9.22, Gimp-2.8.22, Graphviz-2.40.1, Inkscape-0.92.2, Blender, corefonts, GhostPCL, Gnuplot, POV-Ray, and Radiance

Optional Conversion Tools

Enscript-1.6.6, texlive-20170524 (or install-tl-unx) AutoTrace, GeoExpress Command Line Utilities, AKA MrSID Utilities (binary package), hp2xx, html2ps, libwmf, UniConvertor, and Utah Raster Toolkit (or URT-3.1b)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/imagemagick

Installation of ImageMagick-6 libraries

Install ImageMagick by running the following commands:

patch -Np1 -i ../ImageMagick-6.9.9-23-libs_only-1.patch &&
./configure --prefix=/usr     \
            --sysconfdir=/etc \
            --enable-hdri     \
            --with-modules    \
            --disable-static  &&
make

Now, as the root user:

make DOCUMENTATION_PATH=/usr/share/doc/imagemagick-6.9.9 install-libs-only

To test the installation, issue: make check. Note that the EPS, PS, and PDF tests require a working Ghostscript. One test in 'make check' needs “Helvetica” from “Ghostscript Standard Fonts”, which are optionally installed in ghostscript-9.22 - that test, and one other, might fail, but all the validation can still pass.

Command Explanations

patch -Np1 -i ../ImageMagick-6.9.9-imagemagick6_libs_only-1.patch: Move unversioned pkgconfig files to versioned names and provide an option to only install libraries and associated files.

--enable-hdri: Enables building of a high dynamic range version of ImageMagick.

--with-modules: Enables support for dynamically loadable modules.

--disable-static: This switch prevents installation of static versions of the libraries.

--with-gslib: Enables support to use the Ghostscript shared library.

--with-rsvg: Enables support to use the librsvg library.

--with-autotrace: Enables support to use the Autotrace library.

--with-wmf: Enables support to use the libwmf library.

--with-gvc: Enables support to use GraphViz.

--with-windows-font-dir= <Some/Directory>: This option specifies the directory where the Windows CoreFonts are installed.

--with-dejavu-font-dir= <Some/Directory>: This option specifies the directory where the DejaVu fonts are installed.

The options and parameters listed above are the only ones you should have to pass to the configure script to activate all the delegate dependencies. All other dependencies will be automatically detected and utilized in the build if they are installed.

Contents

Installed Programs: None
Installed Libraries: libMagickCore-6.Q16HDRI.so, libMagickWand-6.Q16HDRI.so and libMagick++-6.Q16HDRI.so
Installed Directories: /etc/ImageMagick-6, /usr/include/ImageMagick-6, /usr/lib/ImageMagick-6.9.9, /usr/share/doc/ImageMagick-6.9.9, and /usr/share/ImageMagick-6

Short Descriptions

libMagickCore-6.Q16HDRI.so

provides the C API for ImageMagick.

libMagickWand-6.Q16HDRI.so

is the recommended C API for ImageMagick. Unlike the MagickCore API it uses only a few opaque types.

libMagick++-6.Q16HDRI.so

provides the C++ API for ImageMagick.

Last updated on 2017-11-16 16:03:21 -0600