Introduction to the Phonon-backend-vlc

This package provides a Phonon backend which utilizes the VLC media framework.

This package is known to build and work properly using an LFS-8.2 platform.

Package Information

Phonon-backend-vlc Dependencies


phonon-4.10.0 and VLC-3.0.0

User Notes:

Installation of Phonon-backend-vlc



This package unpacks to the directory phonon-vlc-0.10.0.

Install Phonon-backend-vlc by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr    \
      -DCMAKE_BUILD_TYPE=Release     \
      -Wno-dev .. &&

Now, as the root user:

make install

Command Explanations

-DCMAKE_BUILD_TYPE=Release: This switch is used to apply higher level of compiler optimizations.

-DPHONON_BUILD_PHONON4QT5=ON: This switch is used to ensure that Qt5 version of the backend is built even if Qt4 is present.


Installed Program: none
Installed Libraries:
Installed Directory: /usr/lib/qt5/plugins/phonon4qt5_backend

Last updated on 2018-02-24 20:27:10 -0800