xine-lib-1.2.6

Introduction to Xine Libraries

The Xine Libraries package contains xine libraries. These are useful for interfacing with external plug-ins that allow the flow of information from the source to the audio and video hardware.

This package is known to build and work properly using an LFS-7.9 platform.

This package is known to build properly using the gcc-6 compiler.

Package Information

Xine Libraries Dependencies

Required

X Window System, FFmpeg-3.1.2, and at least one of: ALSA-1.1.2, PulseAudio-9.0 or JACK

Recommended

Optional

AAlib-1.4rc5, FAAD2-2.7, FLAC-1.3.1, gdk-pixbuf-2.34.0, GLU-9.0.0, ImageMagick-7.0.1-10, liba52-0.7.4, libmad-0.15.1b, libmng-2.0.3, libtheora-1.1.1, libva-1.7.1, libvdpau-1.1.1, libvorbis-1.3.5, libvpx-1.6.0, Mesa-12.0.1, Samba-4.4.5, SDL-1.2.15, Speex-1.2rc2, Doxygen-1.8.11 (to create the API documentation), v4l-utils-1.10.1 DirectFB, libbluray, libcaca, libdca, libFAME, libmodplug, musepack, VCDImager, and WavPack,

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/xine-lib

Installation of Xine Libraries

Install Xine Libraries by running the following commands:

sed -e 's/avcodec_alloc_frame/av_frame_alloc/'            \
        -e 's/avcodec_free_frame/av_frame_free/'          \
        -i src/combined/ffmpeg/ff_{audio,video}_decoder.c \
           src/dxr3/ffmpeg_encoder.c &&

sed -e 's|wand/magick_wand.h|MagickWand/MagickWand.h|' \
    -i src/video_dec/image.c &&

sed -e '/xineplug_vo_out_xcbxv_la_LIBADD/s/$(XCB_LIBS)/$(XCBSHM_LIBS) $(XCB_LIBS)/' \
    -i src/video_out/Makefile.in &&
sed -e 's/\(xcb-shape >= 1.0\)/xcb \1/' -i m4/video_out.m4 &&

./configure --prefix=/usr          \
            --disable-vcd          \
            --with-external-dvdnav \
            --docdir=/usr/share/doc/xine-lib-1.2.6 &&
make

To create the API documentation, Doxygen must be installed and issue the following command:

doxygen doc/Doxyfile

This package does not come with a test suite.

Now, as the root user:

make install
[Note]

Note

When installing, the Makefile does some additional linking. If you do not have Xorg in /usr, the LIBRARY_PATH variable needs to be defined for the root user. If using sudo to assume root, use the -E option to pass your current environment variables for the install process.

If you built the API documentation, issue the following commands as the root user to install it:

install -v -m755 -d /usr/share/doc/xine-lib-1.2.6/api &&
install -v -m644    doc/api/* \
                    /usr/share/doc/xine-lib-1.2.6/api

Command Explanations

sed ...: These commands enable the package to be built with FFmpeg-3.1.2, ImageMagick-7.0.1-10 and libxcb-1.12.

--with-external-dvdnav: This switch is required, because internal libraries cannot decrypt DVD.

--disable-vcd: This switch is required to compile Xine Lib without VCDImager installed. Remove this option if you have installed VCDImager.

--with-external-dvdnav: This switch is required, because internal libraries cannot decrypt DVD.

--docdir=/usr/share/xine-lib-1.2.6: This switch causes the documentation to be installed into a versioned directory instead of the default /usr/share/doc/xine-lib.

Contents

Installed Programs: xine-config and xine-list-1.2
Installed Libraries: libxine.so and numerous plugin modules and video extensions under /usr/lib/xine/plugins/2.5
Installed Fonts: Output display engine fonts located in /usr/share/xine-lib/fonts
Installed Directories: /usr/include/xine, /usr/lib/xine, /usr/share/xine-lib, and /usr/share/doc/xine-lib-1.2.6

Short Descriptions

xine-config

provides information to programs trying to link with the xine libraries.

xine-list-1.2

is used to get supported filetype information from xine-lib.

libxine.so

provides the API for processing audio/video files.

Last updated on 2016-08-13 15:35:52 -0500