LAME-3.99.5

Introduction to LAME

The LAME package contains an MP3 encoder and optionally, an MP3 frame analyzer. This is useful for creating and analyzing compressed audio files.

This package is known to build and work properly using an LFS-7.5 platform.

Package Information

LAME Dependencies

Optional

Dmalloc, Electric Fence, libsndfile-1.0.25 and NASM-2.11.05

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/lame

Installation of LAME

First, if you are using i686, fix a compile problem inroduced by gcc-4.9.0:

sed -i -e '/xmmintrin\.h/d' configure

Install LAME by running the following commands:

./configure --prefix=/usr --enable-mp3rtp --disable-static &&
make

To test the results, issue: make test.

Now, as the root user:

make pkghtmldir=/usr/share/doc/lame-3.99.5 install

Command Explanations

sed -i -e '/xmmintrin\.h/d' configure : with gcc-4.9.0, 32-bit i686 builds fail in xmm_quantize_sub.c with an error message error: inlining failed in call to always_inline '_mm_loadu_ps'. This sed makes it appear as if xmmintrin.h is not present. Do not use this on other versions of gcc, or on x86_64.

--enable-mp3rtp: This switch enables building of the encode-to-RTP program.

--disable-static: This switch prevents installation of static versions of the libraries.

--enable-nasm: Enable the use of NASM-2.11.05 to compile optimized assembly routines.

Contents

Installed Programs: lame and mp3rtp
Installed Library: libmp3lame.so
Installed Directories: /usr/include/lame and /usr/share/doc/lame-3.99.5

Short Descriptions

lame

creates MP3 audio files from raw PCM or .wav data.

mp3rtp

is used to encode MP3 with RTP streaming of the output.

libmp3lame.so

libraries provide the functions necessary to convert raw PCM and WAV files to MP3 files.

Last updated on 2014-08-06 14:52:27 +0000