gst-plugins-ugly-1.2.4

Introduction to GStreamer Ugly Plug-ins

The GStreamer Ugly Plug-ins is a set of plug-ins considered by the GStreamer developers to have good quality and correct functionality, but distributing them might pose problems. The license on either the plug-ins or the supporting libraries might not be how the GStreamer developers would like. The code might be widely known to present patent problems.

This package is known to build and work properly using an LFS-7.5 platform.

[Note]

Note

GStreamer 1.0 series is not API or ABI compatible with GStreamer 0.10 series and both can be installed on the same system.

Package Information

GStreamer Ugly Plug-ins Dependencies

Required

gst-plugins-base-1.2.4

Recommended

Optional

liba52-0.7.4, libmad-0.15.1b, libmpeg2-0.5.1, libcdio, libsidplay, OpenCore AMR, ORC, and TwoLame

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gst10-plugins-ugly

Installation of GStreamer Ugly Plug-ins

Install GStreamer Ugly Plug-ins by running the following commands:

./configure --prefix=/usr \
            --with-package-name="GStreamer Ugly Plugins 1.2.4 BLFS" \
            --with-package-origin="http://www.linuxfromscratch.org/blfs/view/svn/" &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Contents

Installed Programs: None
Installed Libraries: Several plugins under /usr/lib/gstreamer-1.0
Installed Directory: /usr/share/gstreamer-1.0/presets

Last updated on 2014-04-21 20:43:54 +0000