gst-plugins-good-0.10.31

Introduction to GStreamer Good Plug-ins

The GStreamer Good Plug-ins is a set of plug-ins considered by the GStreamer developers to have good quality code, correct functionality, and the preferred license (LGPL for the plug-in code, LGPL or LGPL-compatible for the supporting library). A wide range of video and audio decoders, encoders, and filters are included. Also see the gst-plugins-ugly-0.10.19, gst-plugins-bad-0.10.23 and gst-ffmpeg-0.10.13 packages.

This package is known to build and work properly using an LFS-7.6 platform.

[Note]

Note

GStreamer 1.0 series is not API or ABI compatible with GStreamer 0.10 series and both can be installed on the same system.

Package Information

GStreamer Good Plug-ins Dependencies

Required

gst-plugins-base-0.10.36

Recommended

Optional (Required if building GNOME)

GConf-3.2.6 and libsoup-2.48.0

Optional

AAlib-1.4rc5, GTK+-3.14.1 (required to build the examples), libdv-1.0.0, PulseAudio-5.0, Speex-1.2rc1, taglib-1.9.1, JACK, libavc1394 (requires libraw1394), libcaca, libcdio, libiec61883, libshout, ORC, Video4Linux and WavPack

Optional, for the unit regression tests

Valgrind-3.10.0

Optional (Required to Rebuild the API Documentation)

GTK-Doc-1.21 and Python-2.7.8

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gst-plugins-good

Installation of GStreamer Good Plug-ins

[Note]

Note

If you need a plugin for a given dependency, that dependency needs to be installed before this application.

Install GStreamer Good Plug-ins by running the following commands:

sed -i -e "/input:/d" sys/v4l2/gstv4l2bufferpool.c &&
sed -i -e "/case V4L2_CID_HCENTER/d" -e "/case V4L2_CID_VCENTER/d" sys/v4l2/v4l2_calls.c &&
./configure --prefix=/usr \
            --sysconfdir=/etc \
            --with-gtk=3.0 &&
make

To run the unit regression tests, issue: make check. There are many other Makefile targets you can specify for running the tests, issue make -C tests/check help to see the complete list.

Now, as the root user:

make install

If you did not rebuild the API documentation by passing --enable-gtk-doc to the configure script and you wish to install the pre-built documentation, issue the following command as the root user:

make -C docs/plugins install-data

Command Explanations

sed -i -e "...": These sed commands fix building with recent kernels.

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.

Contents

Installed Programs: None
Installed Libraries: None
Installed Directory: /usr/share/gtk-doc/html/gst-plugins-good-plugins-0.10

Last updated on 2014-09-22 18:20:08 +0000