Nepomuk-widgets-4.13.0

Introduction to nepomuk-widgets

Nepomuk-widgets contains the widget library for the Nepomuk Semantik Desktop.

This package is known to build and work properly using an LFS-7.5 platform.

Package Information

Nepomuk-widgets Dependencies

Required

nepomuk-core-4.13.0

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/nepomuk-widgets

Installation of nepomuk-widgets

Install nepomuk-widgets by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KDE_PREFIX \
      -DCMAKE_BUILD_TYPE=Release         \
      -Wno-dev .. &&
make

To test the results, issue make test.

Now, as the root user:

make install

Contents

Installed Programs: none
Installed Libraries: libnepomukwidgets.so
Installed Directories: $KDE_PREFIX/include/nepomuk2 and $KDE_PREFIX/lib/cmake/NepomukWidgets

Last updated on 2014-04-17 09:42:57 +0000