Tracker-miners-2.3.1

Introduction to Tracker-miners

The Tracker-miners package contains a set of data extractors for Tracker.

This package is known to build and work properly using an LFS-9.0 platform.

Package Information

Additional Downloads

Tracker-miners Dependencies

Required

gst-plugins-base-1.16.2, Tracker-2.3.1, Exempi-2.5.1, and gexiv2-0.12.0

Recommended

Optional

CMake-3.16.2, DConf-0.34.0, libgsf-1.14.46, libseccomp-2.4.2, taglib-1.11.1, totem-pl-parser-3.26.4, UPower-0.99.11, libcue, libosinfo, and gupnp

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/tracker-miners

Installation of Tracker-miners

First, apply some fixes from upstream that fix deadlock bugs:

patch -Np1 -i ../tracker-miners-2.3.1-upstream_fixes-1.patch

Install Tracker-miners by running the following commands:

mkdir build &&
cd    build &&

meson --prefix=/usr .. &&
ninja

To test the results, as the root user, issue: ninja test.

Now, as the root user:

ninja install

Command Explanations

-Dminer_rss=false: Use this option if you have not installed the recommended dependency libgrss.

Contents

Installed Programs: None
Installed Libraries: libtracker-extract.so, and several modules under /usr/lib/tracker-miners-2.0.
Installed Directories: /usr/lib/tracker-miners-2.0 and /usr/share/tracker-miners

Last updated on 2019-12-06 00:19:29 -0600