Gjs-1.42.0

Introduction to Gjs

Gjs is a Javascript binding for GNOME.

This package is known to build and work properly using an LFS-7.6 platform.

Package Information

Gjs Dependencies

Required

Cairo-1.14.0, gobject-introspection-1.42.0, and JS2-24.2.0

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gjs

Installation of Gjs

Install Gjs by running the following commands:

./configure --prefix=/usr &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Contents

Installed Programs: gjs (symlink) and gjs-console
Installed Library: libgjs.so
Installed Directories: /usr/include/gjs-1.0, /usr/lib/gjs, and /usr/libexec/gjs

Short Descriptions

libgjs.so

contains the GNOME JavaScript bindings.

Last updated on 2014-10-19 14:37:08 +0000