JS-24.2.0

Introduction to JS

JS is Mozilla's JavaScript engine written in C/C++.

This package is known to build and work properly using an LFS-7.5 platform.

Package Information

JS Dependencies

Required

libffi-3.1, NSPR-4.10.6, Python-2.7.8 and Zip-3.0

Optional

Doxygen-1.8.7

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/JS2

Installation of JS

[Note]

Note

This package can be installed without problems, if you have installed JS-17.0.0. It is necessary to set SHELL=/bin/bash if you are working in chroot.

Install JS by running the following commands:

cd js/src &&
./configure --prefix=/usr       \
            --enable-readline   \
            --enable-threadsafe \
            --with-system-ffi   \
            --with-system-nspr &&
make

To test the results, issue: make check.

Now, as the root user:

make install &&
find /usr/include/mozjs-24/         \
     /usr/lib/libmozjs-24.a         \
     /usr/lib/pkgconfig/mozjs-24.pc \
     -type f -exec chmod -v 644 {} \;

Command Explanations

--enable-threadsafe: This switch enables support for multiple threads.

--enable-readline: This switch enables Readline support in JS shell.

--with-system-ffi: This switch forces the package to link to the system version of libffi instead of using its included, and now old, version.

--with-system-nspr: This switch forces the package to link to the system version of NSPR instead of using its included, and now old, version.

Contents

Installed Programs: js24 and js24-config
Installed Libraries: libmozjs-24.a and libmozjs-24.so
Installed Directory: /usr/include/mozjs-24

Short Descriptions

js24

provides a command line interface to the JavaScript engine.

js24-config

is used to find out JS compiler and linker flags.

libmozjs-24.so

contains the Mozilla JavaScript API functions.

Last updated on 2014-03-31 18:48:21 +0000