GeoClue-0.12.0

Introduction to GeoClue

GeoClue is a modular geoinformation service built on top of the D-Bus messaging system. The goal of the GeoClue project is to make creating location-aware applications as simple as possible.

This package is known to build and work properly using an LFS-7.6 platform.

Package Information

Additional Downloads

GeoClue Dependencies

Required

dbus-glib-0.102, GConf-3.2.6 and libxslt-1.1.28

Recommended if you are building GNOME

Optional

GPSD, GTK+-2.24.25 and oFono

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/geoclue

Installation of GeoClue

Install GeoClue by running the following commands:

patch -Np1 -i ../geoclue-0.12.0-gpsd_fix-1.patch &&
sed -i "s@ -Werror@@" configure &&
sed -i "s@libnm_glib@libnm-glib@g" configure &&
sed -i "s@geoclue/libgeoclue.la@& -lgthread-2.0@g" \
       providers/skyhook/Makefile.in &&
./configure --prefix=/usr &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

sed -i "s@ -Werror@@" configure: This sed removes -Werror from the CFLAGS variable, otherwise the build will fail with gcc-4.7.

sed -i "s@libnm_glib@libnm-glib@g" configure: This sed fixes detection of NetworkManager libraries.

sed -i "s@geoclue/libgeoclue.la@& -lgthread-2.0@g" .. : This sed fixes building GeoClue with recent binutils.

Contents

Installed Programs: None
Installed Library: libgeoclue.so
Installed Directory: /usr/include/geoclue, /usr/share/geoclue-providers, and /usr/share/gtk-doc/html/geoclue

Short Descriptions

libgeoclue.so

contains functions that provide the GeoClue geoinformation application programming interface.

Last updated on 2014-10-19 14:37:08 +0000