ESP Ghostscript-7.07.1

Introduction to ESP Ghostscript

ESP Ghostscript is a versatile processor for PostScript data with the ability to render PostScript to different targets. ESP Ghostscript is a customized version of GNU Ghostscript that includes an enhanced configuration script, the CUPS raster driver to support CUPS raster printer drivers, and additional patches and drivers from various Linux distributors.

Package Information

Additional Downloads

Standard Fonts

Other Fonts

ESP Ghostscript Dependencies


CUPS-1.1.23, libjpeg-6b, libpng-1.2.8, X (XFree86-4.5.0 or, GLib-1.2.10, GTK+-1.2.10 and Gimp-Print-4.2.7

Installation of ESP Ghostscript

Install ESP Ghostscript by running the following commands:

./configure --prefix=/usr --without-gimp-print --without-omni &&

Now, as the root user:

make install

To install the shared library you will need GTK+-1.2.10.

Proceed with the following commands:

make CFLAGS_SO='-fPIC $(ACDEFS)' so

Now, as the root user:

make soinstall &&
install -v -d -m755 /usr/include/ps &&
install -v -m644 src/*.h /usr/include/ps


The shared library is only used in external programs like GSview-4.7.

To finish the installation, unpack all fonts you've downloaded to /usr/share/ghostscript and ensure the ownerships of the files are root:root. Substitute [font-tarball] appropriately in the command below for the fonts you wish to install:

tar -zxvf ../[font-tarball] -C /usr/share/ghostscript &&
chown -v -R root:root /usr/share/ghostscript/fonts

Command Explanations

--without-gimp-print: This switch disables the building of the GIMP print driver as a Ghostscript device since this is deprecated. This driver may be still accessible via IJS or CUPS, and this is the preferred way.

--without-omni: This switch disables the omni driver support.

--without-ijs: This switch disables the IJS driver support.

install ...: Some packages (ImageMagick is one) need the Ghostscript headers in place to link to the shared library. These commands install the headers.


Installed Programs: bdftops, dvipdf, eps2eps,, font2c, gs, gsbj, gsc, gsdj, gsdj500, gslj, gslp, gsnd, gsx,, pdf2dsc, pdf2ps, pdfopt, pf2afm, pfbtopfa,, printafm, ps2ascii, ps2epsi, ps2pdf, ps2pdf12, ps2pdf13, ps2pdf14, ps2pdfwr, ps2ps,,,, and wftopfa
Installed Library:
Installed Directories: /usr/include/ps and /usr/share/ghostscript

Short Descriptions


invokes Ghostscript, an interpreter of Adobe Systems' PostScript(tm) and Portable Document Format (PDF) languages.


is a filter used by CUPS to convert PostScript to a generic raster image format that is acceptable as an input to drivers for non-PostScript printers (e.g., from Gimp-Print-4.2.7). It is built and installed only if CUPS-1.1.23 is found.

ESP Ghostscript provides many different scripts used to render PostScript/PDF files back and forth. Please refer to the HTML documentation or try man gs for information about the capabilities provided by the package.

Last updated on 2005-08-01 13:29:19 -0600