Introduction to Gst-plugins

The gst-plugins package builds graphics and multimedia CODEC interface modules for the GStreamer package. There are over 160 different modules that can be built, providing GStreamer the capability to create a pipeline for almost every known media stream.

Package Information

Gst-plugins Dependencies



Optional Utilities (Graphics, Compression, Misc.)

AAlib-1.4rc5, Cairo, CDParanoia-III-9.8, FreeType-2.1.10, GConf-2.10.0, GTK+-2.6.7, GNOME Virtual File System-2.10.1, Hermes, libcaca, libcolorspace, libjpeg-6b or MMX Jpeg, libmmx, libmng-1.0.9, liboil, libpng-1.2.8, NASM-0.98.39, Pango-1.8.1, X (XFree86-4.5.0 or

Optional Audio Libraries/Drivers/CODECs

ALSA-1.0.9, aRts-1.4.1, Audio File-0.2.6, audioresample, EsounD-0.2.35, FAAC, FAAD2, FLAC-1.1.2, GSM, JACK, LAME-3.96.1, liba52-0.7.4, libcdaudio, libdts, libmad-0.15.1b (and libid3tag), libmikmod-3.1.11, libmusepack (now known as libmpcdec), libmusicbrainz, libogg-1.1.2, libraw1394 (and libavc1394), libshout, libsidplay, libsndfile, libvorbis-1.1.1, LADSPA, NAS-1.7, Polypaudio, Speex >= 1.1.6, Theora, Tremor

Optional Video Libraries/Drivers/CODECs

Dirac, DirectFB, DivX4Linux, DXR3, libdv-0.104, libdvdnav, libdvdread-0.9.4, libFAME-0.9.1, libmpeg2, librfb, MJPEG Tools, V4L2, XviD-1.0.3

Optional Multimedia Utilities

libmms, libvisual, SDL-1.2.8, swfdec and xine Libraries-1.0.1

Installation of Gst-plugins

Install gst-plugins by running the following commands:

./configure --prefix=/usr --sysconfdir=/etc &&

This package does not come with a test suite.

Now, as the root user:

make install &&

Command Explanations

--with-gconf-schema-file-dir=/etc/gnome/gconf/schemas: Use this option if you have the GNOME-2 GConf package installed.

--enable-gdk-pixbuf-loader: Use this option to build the GDK pixbuf loader module if you have GTK+-2 installed.

-enable-xine: Using this option to build the Xine wrapper module will break the build if you have xine-libs-1.0.1 installed.

--disable-musepack: Use this option if you have libmusepack-1.1.1 installed, as this version of libmusepack breaks the build.

Note: all other modules are built if the configure script discovers the required package. To prevent a module from being built, pass --disable-[module] to configure. Run configure --help for all the available module names.


Installed Programs: gst-launch-ext-0.8 and gst-visualise-0.8
Installed Libraries: libgst*.[so,a], numerous GStreamer plugins, and a Gstreamer GDK pixbuf loader module
Installed Directories: None

Short Descriptions


is used to run a basic predefined GStreamer pipeline as a quick test to ensure proper working of codecs and GStreamer.


is used to run a basic GStreamer pipeline to display a graphical visualisation of an audio stream.

Last updated on 2005-08-01 13:29:19 -0600