GNOME Speech-0.3.7

Introduction to GNOME Speech

The GNOME Speech package provides a simple general API for producing text-to-speech output. Multiple backends are supported by the GNOME Speech library, but currently only the Festival backend is built by default; the other backends require either Java or proprietary software.

Package Information

GNOME Speech Dependencies




Java Access Bridge-1.4.5, FreeTTS-1.2.1, Festival, ViaVoice, Eloquence, DECTalk and Theta

Installation of GNOME Speech



You must install at least one of the backend drivers for GNOME Speech to render speech through the audio hardware. Testing the installation of the backend driver to ensure it produces desired results before installing GNOME Speech is recommended.

Install GNOME Speech by running the following commands:

./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` &&

This package does not come with a test suite.

Now, as the root user:

make install &&
install -v -m644 -D doc/gnome-speech.html \
    `pkg-config --variable=prefix ORBit-2.0`\

Command Explanations

--with-jab-dir=`pkg-config --variable=prefix ORBit-2.0`/share/jar: Use this option if you have installed the Java Access Bridge package and wish to have GNOME Speech build in Java support.

Note: see the README and INSTALL files in the package source tree for the correct parameters to pass to configure to enable the desired backends.

Testing the Installation

You can test all the available backend drivers, voices and audio hardware using the test-speech command. Invoking test-speech produces a menu allowing you to select a backend driver and the desired voice, then prompts you (with on-screen prompts and text-to-speech audio) for additional information.


Installed Programs: festival-synthesis-driver, freetts-synthesis-driver and test-speech
Installed Library: libgnomespeech.[so,a]. Other drivers and libraries are also installed if you have enabled additional backends.
Installed Directories: $GNOME_PREFIX/include/gnome-speech-1.0, $GNOME_PREFIX/share/doc/gnome-speech-0.3.7, $GNOME_PREFIX/share/gnome-speech and $GNOME_PREFIX/share/idl/gnome-speech-1.0

Short Descriptions


is used to test the various backend drivers and voices installed on the system.


provides the API for programs to convert text into speech.

Last updated on 2005-08-01 13:29:19 -0600