Introduction to Gimp-Print

The Gimp-Print package contains high quality drivers for Canon, Epson, Lexmark and PCL printers for use with ESP Ghostscript-7.07.1, CUPS-1.1.23, Foomatic, LPRng-3.8.28, lpr and the GIMP-1.2. See a list of supported printers at

Package information

Gimp-Print dependencies

Installation of Gimp-Print

Install Gimp-Print by running the following commands:

./configure --prefix=/usr &&
make &&
make install

Command explanations

--with-translated-ppds=no: When this switch is given, only US English PPD files for CUPS will be built. Useful if the PPD files are not yet translated into your native language and you want to save some space by not installing unneeded translations.

--enable-cups-level3-ps: This option causes the build process to generate PostScript level 3 PPD files instead of level 2 ones.

Configuring Gimp-Print

Configuration Information

For CUPS to see newly installed PPD files, it has to be restarted:

/etc/rc.d/init.d/cups restart


This command may take a very long time (up to 10 minutes) to complete. Don't panic while CUPS is rescanning the list of PPD files. The long delay will happen only once.

Then point your web browser to to add a new printer to CUPS.


The Gimp-Print package contains gimpprint-config, escputil, libgimpprint libraries and optionally, rastertoprinter and pstopxl filter scripts for CUPS, cups-calibrate, ijsgimpprint and a plugin that allows printing images from GIMP-1.2.



gimpprint-config is a script to get information about the installed version of gimpprint.


escputil is a command line utility to perform various maintenance tasks on Epson Stylus inkjet printers.


cups-calibrate calibrates the color output of printers using the Gimp-Print CUPS or ESP Print Pro drivers.


ijsgimpprint is a Ghostscript driver for Gimp-Print.

Last updated on 2005-02-15 13:57:55 -0700