Introduction to libxfce4util

The libxfce4util package is a basic utility library for the Xfce desktop environment.

This package is known to build and work properly using an LFS-7.5 platform.

Package Information

libxfce4util Dependencies


GLib-2.38.2 and Intltool-0.50.2



User Notes:

Installation of libxfce4util

Install libxfce4util by running the following commands:

./configure --prefix=/usr --sysconfdir=/etc &&

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.


Installed Program: xfce4-kiosk-query
Installed Library:
Installed Directories: /usr/include/xfce4 and /usr/share/gtk-doc/html/libxfce4util

Short Descriptions


Queries the given capabilities of <module> for the current user and reports whether the user has the capabilities or not. This tool is mainly meant for system administrators to test their Kiosk setup.

contains basic utility functions for the Xfce desktop environment.

Last updated on 2014-02-20 10:20:46 -0800