Introduction to GPGME

The GPGME package is a C language library that allows to add support for cryptography to a program. It is designed to make access to public key crypto engines like GnuPG or GpgSM easier for applications. GPGME provides a high-level crypto API for encryption, decryption, signing, signature verification and key management.

This package is known to build and work properly using an LFS-7.4 platform.

Package Information

GPGME Dependencies




GnuPG-1.4.14 or GnuPG-2.0.21 (used during the testsuite)

User Notes:

Installation of GPGME

Install GPGME by running the following commands:

./configure --prefix=/usr --disable-fd-passing &&

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--disable-fd-passing: This option disables a problem causing a hang for some operations on some systems.


Installed Program: gpgme-config
Installed Libraries: and
Installed Directory: /usr/share/common-lisp/source/gpgme

Short Descriptions

contains the GPGME API functions for applications using pthread.

contains the GPGME API functions.

Last updated on 2013-08-23 03:32:24 -0700