Introduction to GStreamer Ugly Plug-ins

The GStreamer Ugly Plug-ins is a set of plug-ins considered by the GStreamer developers to have good quality and correct functionality, but distributing them might pose problems. The license on either the plug-ins or the supporting libraries might not be how the GStreamer developers would like. The code might be widely known to present patent problems. Also see the gst-plugins-bad-0.10.23, gst-plugins-good-0.10.31 and gst-ffmpeg-0.10.13 packages.

This package is known to build and work properly using an LFS-7.4 platform.



GStreamer 1.0 series is not API or ABI compatible with GStreamer 0.10 series and both can be installed on the same system.

Package Information

Additional Downloads

GStreamer Ugly Plug-ins Dependencies





liba52-0.7.4, libcdio, libmad-0.15.1b, libmpeg2-0.5.1, libsidplay, OpenCore AMR, ORC, TwoLAME and x264

Optional, for the unit regression tests


Optional (Required to Rebuild the API Documentation)

GTK-Doc-1.19 and Python-2.7.5 (compiled against an XML parser such as expat-2.1.0)

User Notes:

Installation of GStreamer Ugly Plug-ins

Install GStreamer Ugly Plug-ins by running the following commands:

patch -Np1 -i ../gst-plugins-ugly-0.10.19-libcdio_fixes-1.patch &&
./configure --prefix=/usr &&

To run the unit regression tests, issue: make check.

Now, as the root user:

make install

If you did not rebuild the API documentation by passing --enable-gtk-doc to the configure script and you wish to install the pre-built documentation, issue the following command as the root user:

make -C docs/plugins install-data

Command Explanations

--enable-gtk-doc: Use this parameter if GTK-Doc is installed and you wish to rebuild and install the API documentation.


Installed Programs: None
Installed Libraries: None
Installed Directory: /usr/share/gtk-doc/html/gst-plugins-ugly-plugins-0.10

Last updated on 2013-08-24 04:19:06 -0700