Introduction to libxml2

The libxml2 package contains XML libraries. These are useful for parsing XML files.

Package Information

libxml2 Dependencies


libxslt-1.1.22 (used for the test suite if found, but not required) and Python-2.5.2 (will install a Python library module if found)

Optional (Required to Run the Full Suite of Tests)

Python-2.5.2 and Wget-1.10.2



Some packages which utilize libxml2 (such as GNOME Doc Utils) need the Python module installed to function properly and some packages (such as GNOME Panel) will not build properly if the Python module is not available.

User Notes:

Installation of libxml2

Install libxml2 by running the following commands:

./configure --prefix=/usr &&

To test the results, issue: make check.

Now, as the root user:

make install

Command Explanations

--with-history: If this option is used, it enables readline support when running xmlcatalog or xmllint in shell mode.



When using history support, make check will hang forever if either /etc/inputrc or ~/.inputrc has the option show-all-if-ambiguous or show-all-if-available turned on.


Installed Programs: xml2-config, xmlcatalog, and xmllint
Installed Libraries: libxml2.{so,a} and optionally, the libxml2mod.{so,a} Python module
Installed Directories: /usr/include/libxml2, /usr/share/doc/libxml2-2.6.31, /usr/share/doc/libxml2-python-2.6.31 and /usr/share/gtk-doc/html/libxml2

Short Descriptions


determines the compile and linker flags that should be used to compile and link programs that use libxml2.


is used to monitor and manipulate XML and SGML catalogs.


parses XML files and outputs reports (based upon options) to detect errors in XML coding.


libraries provide the functions for programs to parse files that use the XML format.

Last updated on 2008-03-09 09:20:31 -0500