Introduction to libgnomecups

The libgnomecups package contains a library used to wrap the CUPS API in a GLib fashion, so CUPS code can be cleanly integrated with GLib code.

Package Information

libgnomecups Dependencies


CUPS-1.2.7, GLib-2.10.3, and XML::Parser-2.34



User Notes:

Installation of libgnomecups



The instructions below are based on installing the package into a GNOME-2 environment. If, for whatever reason, you're installing this package without having ORBit2 and the core GNOME-2 libraries installed, you'll need to modify the --prefix= parameter on the configure script to point to your desired installation path (e.g., --prefix=/usr).

Install libgnomecups by running the following commands:

./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) &&

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--prefix=$(pkg-config --variable=prefix ORBit-2.0): Setting the prefix using this parameter instead of with $GNOME_PREFIX will ensure that the prefix is consistent with the installation environment and the package will be installed in the correct location.


Installed Programs: None
Installed Library: libgnomecups-1.0.{so,a}
Installed Directory: $GNOME_PREFIX/include/libgnomecups-1

Short Descriptions


libraries are used to wrap the CUPS API in a GLib type interface.

Last updated on 2007-01-18 13:38:19 -0600