Prerequisites

nALFS v1.2 requires a functioning Linux system with the following libraries and programs already installed and configured.

Ncurses

Any recent version should work. If for some reason your system does not have ncurses installed, the LFS book provides an excellent installation procedure at http://www.linuxfromscratch.org/lfs/view/cvs/chapter06/ncurses.html.

libXML2

Any version greater than or equal to v2.6.0 should work. One primary feature you are looking for is support for XInclude. If for some reason your system does not have libXML2 installed or XInclude compiled in, the BLFS book provides an excellent installation procedure at http://www.linuxfromscratch.org/blfs/view/cvs/general/libxml2.html.

Curl

[Note] Note

This package is optional.

Any version greater than v7.10 should work. If for some reason your system does not have Curl installed, the BLFS book provides an excellent installation procedure at http://www.linuxfromscratch.org/blfs/view/cvs/basicnet/curl.html.

OpenSSL

[Note] Note

This package is optional.

Any version greater than v0.9.7 should work. If for some reason your system does not have OpenSSL installed, the BLFS book provides an excellent installation procedure at http://www.linuxfromscratch.org/blfs/view/cvs/general/openssl.html.

Other

Of course, any system needs to have the following packages installed for the XML handlers to work and to even get the package installed. Links to install procedures are provided, just in case.